Desktop User Guides > Professional > Using UNICOM Intelligence Professional > UNICOM Intelligence Professional reference > UNICOM Intelligence Professional options
 
UNICOM Intelligence Professional options
You can use the UNICOM Intelligence Professional Options dialog to define options that control the appearance and behavior of UNICOM Intelligence Professional. You can open the dialog by choosing Options from the Tools menu. If you click an option, its description appears at the bottom of the dialog.
To change an option
1 For numeric options, click the option and enter the new numeric value.
2 For options that have a limited number of valid values, click the list to select the value you require.
3 For options that require a file or folder name, you can either type in the name directly or click the button at the right end of the option to select a file or folder from a list.
Appearance options
Docking Appearance
For panes, controls the look of the title bar and the caption buttons.
Tab Appearance
For open files in the Edit pane, controls the look of the tab.
Toolbar Appearance
Controls the look of the toolbars.
Application options
Number of Recent Files
Controls the number of files that are shown in the list of recent files on the File menu.
Number of Recent Workspaces
Controls the number of workspaces that are shown in the list of recent files on the File menu.
Library Folder
The library files location.
Questionnaire Wizard Template
Default questionnaire wizard template.
Debugging options
Save Before Execution
Controls whether files are automatically saved when you run or debug them.
Interview Browser options
Use Built-in Browser
Determines whether a running interview appears in the Browser pane or a standalone browser. For more information, see Testing an interview.
External Browser Path
(Applies only if Use Built-in Browser is False.) The path for the external browser in which you want to run the interviews.
External Browser Arguments
(Applies only if Use Built-in Browser is False.) Any arguments to be added to the command that starts the external browser.
External Browser Automatic Page Refresh
(Applies only if Use Built-in Browser is False.) Specifies whether the browser refreshes automatically.
In most situations, True is the most useful option. It adds a script to the HTML page to force the automatic update. If the script causes issues, change the value to False: you then have to refresh the browser manually when each new page is posted.
The default value is True.
Interview options
Activate Server or URL
Specifies the target UNICOM Intelligence Interviewer - Server cluster to use when you choose Activate from the UNICOM Intelligence Professional Tools menu. The value of this option depends on whether you are connected to the same local network as the cluster and have access to the FMRoot shared folder on the primary DPM server. If you are connected to the same local network, enter the name of the primary DPM server. If you are not connected to the same local network, enter the URL that you use to login to UNICOM Intelligence Interviewer - Server Admin on that cluster, for example:
http://primary_dpm_server_name/SPSSMR/DimensionNet/default.aspx
If you typically activate to only one cluster, and are connected to the same local network as that cluster, you can stop the activate Login dialog from appearing: enter the name of the primary DPM server, and then set Show Login Dialog to False. For more information, see Activating an interview.
Base Folder for Cache
The location for interview cache files. Typically, you should not need to change this option.
Browser Capabilities
The browser capabilities string that is used when testing in UNICOM Intelligence Professional.
Collect Live Data
Controls whether answers (case data) collected during the running of an interview should be marked as Live or Test. For more information, see Creating case data.
Compare Tool
The name and location of the third-party file compare tool that will be used when you choose Compare from the UNICOM Intelligence Professional Tools menu. For more information, see Comparing interview scripts.
Debug Quotas: Data File Location
The quota data records file location.
Debug Quotas: Display Enabling Message
Determines whether UNICOM Intelligence Professional displays a warning message when you choose Debug Quotas from the UNICOM Intelligence Professional Tools menu. The message says that creating the quota database might take a long time. For more information, see Testing quotas.
Debug Quotas: Report Script Location
Indicates the DebugQuotas.mrs file location. Running the script will displays the quota results in Microsoft Excel.
Default Browser Page
The HTML page that will appear in the Browser pane when no interview is running. If you create your own page, change this value to the name and location of your .htm file.
Default Interview Page
The HTML page that will appear in the Browser pane when an interview is running. If you create your own page, change this value to the name and location of your .htm file.
Error Messages Location
The metadata document (.mdd) file that contains the text for interview error messages. If you create your own error message texts, change this value to the name and location of your .mdd file.
Global Template Folder
The default location for interview template files.
HTML Doctype
The HTML document type declaration to be used for interview pages. Typically, you should not need to change this option.
HTMLOptions: ApplySubTemplatesInGrids
Enables and disables the effects of sub-templates in grid and loop questions.
HTMLOptions: ApplySubTemplatesInNestedBlocks
Question sub-templates are applied to questions in nested blocks.
HTMLOptions: NoAutoJump
Auto jump is disabled for CATI Player questions.
HTMLOptions: NoExpiryMetaTags
Excludes the expiry meta tags in the HTML output.
HTMLOptions: UsePredefinedKeycodes
Uses predefined keycodes for CATI Player questions.
HTMLOptions: UseTablesLayout
Uses table layout for single row/column categorical lists.
HTMLOptions: WebTVSupport
Provides WebTV support.
HTTP Ports
The HTTP ports to use when running interviews. Typically, you should not need to change this option.
Initially Show Metadata View
Determines whether UNICOM Intelligence Professional opens a metadata viewer automatically whenever you open an interview script (.mdd) file (see Using the interview metadata viewer).
Routing Selection Mode
Determines whether the standard HTML player or the CATI HTML player will be used to present the interview. The CATI HTML player allows the interview to be completed using the keyboard only. If you select FromRoutingContext, routing contexts called CATI will automatically use the CATI HTML player and all other routing contexts will use the standard HTML player.
Sample Management Record
The name of the Sample User XML (.xsu) file, which contains a Sample Management record that can be used to test an interview. For more information, see Accessing sample management data.
Shared Content Folder
The location for Shared Content files. This option supports the <mrSharedRef> tag.
Show Login Dialog
Determines whether the Login dialog appears when you choose Activate from the UNICOM Intelligence Professional Tools menu. If you set this to False, you must also enter a URL in the Activate Server or URL option. For more information, see Activating an interview.
Use Hints During Auto Answer
Controls whether the Use hints from .mdd checkbox in the Auto Answer dialog is selected by default. Using hints can degrade the performance of the interview script. For more information, see Running interviews automatically.
Use In-Memory Cache
Controls whether caching will take place in memory or on disk. Typically, you should not need to change this option.
View Metadata and Routing
Controls how UNICOM Intelligence Professional displays the metadata and routing sections of an interview script (.mdd) file. The two sections can be displayed on separate tabs in the Edit pane, or can appear as two halves (top and bottom, or left and right) of the Edit pane. For more information, see Viewing and navigating an interview script.
ScriptAssist options
Show Auto Signature
This option controls whether UNICOM Intelligence Professional displays the syntax of a function or method when you type the opening parenthesis.
Show Auto Suggest
This option controls whether UNICOM Intelligence Professional displays a list of the valid global functions, properties and methods for a variable when you type a dot after the variable's name.
Show Enums
Controls whether the ScriptAssist suggestion list will include enumerators from UNICOM Intelligence Type libraries.
Show Function List
Controls whether the ScriptAssist suggestion list will include functions from the UNICOM Intelligence Function Library.
Show Hidden Members
Controls whether the ScriptAssist suggestion list will include hidden items.
Show ToolTips
When you move your mouse pointer in the Edit window over a function or object property or method, UNICOM Intelligence Professional can display a ToolTip showing the correct syntax. You can use this option to turn this feature on and off.
Text Display options
These options control different aspects of the Edit pane.
Convert Tabs to Spaces
Controls whether tabs are automatically converted to spaces. The number of spaces is determined by the setting of the Tab Indent option.
Default Font
The default font that is used in the Edit pane. To change it, click ... (Browse). Alternatively, you can expand the DefaultFont options by clicking + on the left side. You can then change the suboptions in the normal way.
Italics are not recommended as the default font, because they might be difficult to read in the Edit pane.
Enable Folding
This option enables you to expand and collapse sections of indented code (such as loops and subroutines). By default, all sections are expanded each time you enter the text editor.
Show End Of Line Markers
Controls whether end of line markers are shown.
Show Horizontal Ruler
Controls whether a horizontal ruler is shown at the top of the Edit pane.
Show Icon Bar
This option displays a bar on the left side of the Edit pane on which icons indicate the presence of bookmarks and breakpoints.
Show Invalid Lines
This option indicates the presence of empty lines at the end of a script.
Show Line Numbers
Controls whether line numbers are shown.
Show Matching Braces
Controls whether a pair of matching left and right braces [ and ] are highlighted as you type in the second brace.
Show Spaces
Controls whether space characters are shown as a blue dot.
Show Tabs
Controls whether tab characters are shown
Show Vertical Ruler
Controls whether a vertical ruler is shown on the left side of the Edit pane.
Tab Indent
Controls the number of spaces between tab stops.
See also
UNICOM Intelligence Professional reference